[New-bugs-announce] [issue10881] test_site and macframework builds fails

Stephen Hansen report at bugs.python.org
Mon Jan 10 20:54:07 CET 2011

New submission from Stephen Hansen <me+python at ixokai.io>:

With the latest from branches/py3k, in a framework build, I get:

Wimp:build pythonbuildbot$ ./python.exe -m test.regrtest test_site
[1/1] test_site
test test_site failed -- Traceback (most recent call last):
  File "/Users/pythonbuildbot/32test/build/Lib/test/test_site.py", line 225, in test_getsitepackages
    self.assertEqual(len(dirs), 2)
AssertionError: 3 != 2

1 test failed:
Wimp:build pythonbuildbot$ ./python.exe
Python 3.2b2+ (py3k:87899M, Jan 10 2011, 11:08:48) 
[GCC 4.0.1 (Apple Inc. build 5493)] on darwin
Type "help", "copyright", "credits" or "license" for more information.
>>> import site
>>> site.getsitepackages()
['/Library/Frameworks/Python.framework/Versions/3.2/lib/python3.2/site-packages', '/Library/Frameworks/Python.framework/Versions/3.2/lib/site-python', '/Library/Python/3.2/site-packages']

Those three dirs look correct for me, but the test is written to find exactly two from site.getsitepackages() -- the code, however, adds an extra in the event of framework builds.

assignee: ronaldoussoren
components: Macintosh, Tests
messages: 125919
nosy: ixokai, ronaldoussoren
priority: normal
severity: normal
status: open
title: test_site and macframework builds fails
versions: Python 3.2

Python tracker <report at bugs.python.org>

More information about the New-bugs-announce mailing list