[New-bugs-announce] [issue13362] Many PEP 8 errors

skreft report at bugs.python.org
Mon Nov 7 04:03:50 CET 2011

New submission from skreft <skreft at gmail.com>:

Hi all, I was reading Python's source code and was surprised to find many PEP 8 errors.

The file that I found specially non PEP8 compliant is Lib/encodings/punnycode.py, but there are many others that are not compliant.

I think that this issue should be addressed, since Python's source code should be the model for good Pythonic code.

I would love to contribute on this topic. But since many files would be modified I don't know how to proceed. I see two things that could help to reduce the non compliance of the code. One is to have a website showing the non compliances of each file. And the one I like the most is to have a special test that checks the compliance of the code. The only problem is that it would rely on the external tool pep8 (http://pypi.python.org/pypi/pep8).

Let me know what you think.


messages: 147197
nosy: skreft
priority: normal
severity: normal
status: open
title: Many PEP 8 errors
versions: Python 2.7, Python 3.3

Python tracker <report at bugs.python.org>

More information about the New-bugs-announce mailing list