[New-bugs-announce] [issue13408] Rename packaging.resources back to datafiles

Éric Araujo report at bugs.python.org
Tue Nov 15 14:02:27 CET 2011

New submission from Éric Araujo <merwok at netwok.org>:

The code dealing with the new resources subsystem used to be called datafiles (module distutils2.datafiles, file dist-info/DATAFILES, etc.).  I believe it is a better name and we should use it again:

- it would make clear that it’s an evolution of distutils’ data_files
- it would make clear that it’s related to install_data and data_files

“resources” is overly vague and ambiguous.  It can refer to natural resources, computer resources, links to more information, etc.  “data files” is less vague and less abstract: it refers to files that are not modules, scripts or C files.

assignee: tarek
components: Distutils2
messages: 147665
nosy: alexis, eric.araujo, tarek
priority: normal
severity: normal
status: open
title: Rename packaging.resources back to datafiles
versions: 3rd party, Python 3.3

Python tracker <report at bugs.python.org>

More information about the New-bugs-announce mailing list