[New-bugs-announce] [issue15076] Sometimes couldn't import os, shown 'import site' failed, use -v for trackback

Leon Zhang report at bugs.python.org
Fri Jun 15 11:51:03 CEST 2012

New submission from Leon Zhang <leozhang at cisco.com>:

Hello Experts,

I am using Python 2.6.2 on a Linux machine. I found sometimes I have problem to run my simple python script.

========> Linux version and Python version <========
leonz at fxcsgbu2c1% uname -a
SunOS fxcsgbu2c1 5.8 Generic_117350-06 sun4u sparc SUNW,UltraAX-i2
leonz at fxcsgbu2c1% python
Python 2.6.2 (r262:71600, Sep  9 2009, 06:36:48) 
[GCC 3.4.6] on sunos5
Type "help", "copyright", "credits" or "license" for more information.

========> Problem description <========
I have one python script file located at "/usr/autoprog/LogUtility/pygen.py", the first 4 lines are:
line 1: #!/usr/bin/python
line 2: import sys
line 3: import os
line 4: import traceback

If I just run "python /usr/autoprog/LogUtility/pygen.py" from shell, the script always worked fine.
We are running another application called "autotest" on this machine, "autotest" will create a new process and launch Python in this new process (/usr/bin/python /usr/autoprog/LogUtility/pygen.py) to run my Python script.
Most of the time, the Python script worked fine, but from some time, for some reason, the script suddenty failed, and from this time, if I run autotest to luanch my python script, it always fails, but if I run the python script from shell, it always works fine. If I reboot this machine, both way to run python script works fine. But after some time, run autotest to luanch python script will fail again...
Here is the details of the error message of running autotest to luanch python script:
'import site' failed; use -v for traceback
Traceback (most recent call last):
File "/usr/autoprog/SGBU/LogUtility/pygen.py", line 19, in <module>
import os
File "/usr/local/lib/python2.6/os.py", line 49, in <module>
import posixpath as path
File "/usr/local/lib/python2.6/posixpath.py", line 16, in <module>
import warnings
File "/usr/local/lib/python2.6/warnings.py", line 6, in <module>
import linecache
ImportError: No module named linecache

========> Some other information may help <========
I had searched "'import site' failed; use -v for traceback" on internet, there are also many other people have this problem, but I didn't see any useful information to fix my problem.
Here are some information about the Python on my machine:
Install path is /usr/local/lib/python2.6
There is just one "README" file under /usr/local/lib/python2.6/site-packages

Attached is the python script file "pygen.py". Could any expert help me on this problem? Appreciate if any experts can reply me. Thanks.

components: Library (Lib)
files: pygen.py
messages: 162879
nosy: qtld614
priority: normal
severity: normal
status: open
title: Sometimes couldn't import os, shown 'import site' failed, use -v for trackback
type: crash
versions: Python 2.6
Added file: http://bugs.python.org/file26015/pygen.py

Python tracker <report at bugs.python.org>

More information about the New-bugs-announce mailing list