[New-bugs-announce] [issue14358] test_os failing with errno 61: No Data Available

Ben Hayden report at bugs.python.org
Sun Mar 18 08:16:52 CET 2012


New submission from Ben Hayden <hayden767 at gmail.com>:

When running the test suite on Linux 3.2.9-1, I get the following error on the test_os suite:

test test_os crashed -- Traceback (most recent call last):
  File "/home/benhayden/Documents/cpython/Lib/test/regrtest.py", line 1229, in runtest_inner
    the_package = __import__(abstest, globals(), locals(), [])
  File "/home/benhayden/Documents/cpython/Lib/test/test_os.py", line 1767, in <module>
    @unittest.skipUnless(supports_extended_attributes(),
  File "/home/benhayden/Documents/cpython/Lib/test/test_os.py", line 1754, in supports_extended_attributes
    os.fsetxattr(fp.fileno(), b"user.test", b"")
OSError: [Errno 61] No data available

I don't know the best way to handle this error, but instead of raising it, I just let the decorator return False. This allowed test_os to finish (and finish successfully) on my machine.

Once again, I don't really know what ENODATA might mean, so I just tried the first thing that worked for me.

----------
components: Tests
files: test_os_support_ext.patch
keywords: patch
messages: 156232
nosy: beardedp
priority: normal
severity: normal
status: open
title: test_os failing with errno 61: No Data Available
type: crash
versions: Python 3.3, Python 3.4
Added file: http://bugs.python.org/file24921/test_os_support_ext.patch

_______________________________________
Python tracker <report at bugs.python.org>
<http://bugs.python.org/issue14358>
_______________________________________


More information about the New-bugs-announce mailing list