[New-bugs-announce] [issue26317] Build Problem with GCC + Macintosh OS X 10.11 El Capitain

Robert P Fischer report at bugs.python.org
Mon Feb 8 23:36:24 EST 2016

New submission from Robert P Fischer:

Changes to OS X 10.11 render GCC's Objective-C compiler useless.  However, I want to compile the main part of Python in GCC (because my C++ / Fortran Cython modules use GCC).

I tried to build Python (via MacPorts) using Clang for Objective-C and GCC for C/C++.  The environment upon running ./configure included:


HOWEVER... the build still tried to use GCC to compile Objective-C, and failed miserably:

:info:destroot /Users/rpfische/macports/mpgompi-4.9.3/bin/gcc-mp-4.9 -pipe -Os -arch x86_64 -Wno-unused-result -fno-common -dynamic -DNDEBUG -g -fwrapv -O3 -Wall -Wstrict-prototypes -o FileSettings.o -c ./FileSettings.m
:info:destroot /usr/include/objc/NSObject.h:22:4: error: unknown type name 'instancetype'
:info:destroot  - (instancetype)self;
:info:destroot     ^

Log file attached.

components: Build
files: log
messages: 259914
nosy: Robert P Fischer
priority: normal
severity: normal
status: open
title: Build Problem with GCC + Macintosh OS X 10.11 El Capitain
versions: Python 3.4
Added file: http://bugs.python.org/file41865/log

Python tracker <report at bugs.python.org>

More information about the New-bugs-announce mailing list