[New-bugs-announce] [issue29268] test_spwd fails on solaris using NIS users

Brian Vandenberg report at bugs.python.org
Fri Jan 13 14:43:48 EST 2017

New submission from Brian Vandenberg:

On all our solaris 10 machines when I run a simple test program it never reports a failure when calling getspnam:

   #include <shadow.h>
   #include <stdio.h>
   int main( int, char** ) {
     spwd *asdf = getspnam( "some_user" );
     if( NULL == sdf ) {
       perror( "getspnam" );
     return 0;

If I run the above program on our linux boxes it fails as expected, but on our solaris machines it produces the same information you'd see running "ypcat passwd | grep some_user".

I suspect either there's a bug in the solaris implementation of getpwnam() or perhaps there's a configuration issue on our solaris machines, though it's also possible this is just how it behaves in Solaris (at least with NIS).

As to whether anything should change for test_spwd -- I suspect this will get closed as "won't fix" but at least this report may help anyone else running into this failure.

components: Tests
messages: 285439
nosy: phantal
priority: normal
severity: normal
status: open
title: test_spwd fails on solaris using NIS users
type: behavior
versions: Python 3.6

Python tracker <report at bugs.python.org>

More information about the New-bugs-announce mailing list