[New-bugs-announce] [issue43240] IDLE Classic Unix keyboard shortcuts broken

Alan Moore report at bugs.python.org
Tue Feb 16 13:37:48 EST 2021

New submission from Alan Moore <me at alandmoore.com>:

Using IDLE 3.9.1 on Arch Linux.

In IDLE I've selected the "classic unix" key set.  It worked for a while, then stopped registering key combinations for more than one key (e.g. Ctrl-x Ctrl-s).

Have tried creating a custom key set and manually setting the shortcuts, but it still fails the same way.  Caps lock is not on (disabled on my system).

Have also tried moving configs and starting fresh, does not help.

It had been working, then suddenly stopped in the middle of a work day and I can't get it working again.

assignee: terry.reedy
components: IDLE
messages: 387124
nosy: Alan Moore, terry.reedy
priority: normal
severity: normal
status: open
title: IDLE Classic Unix keyboard shortcuts broken
type: behavior
versions: Python 3.9

Python tracker <report at bugs.python.org>

More information about the New-bugs-announce mailing list