[New-bugs-announce] [issue45075] confusion between frame and frame_summary in traceback module
report at bugs.python.org
Wed Sep 1 07:45:44 EDT 2021
New submission from Irit Katriel <iritkatriel at gmail.com>:
def format_frame(frame) should be renamed to format_frame_summary(frame_summary) because it takes a FrameSummary obejct and not a frame.
This is a new API in 3.11 so it can be changed now.
There are also local variables in traceback.py which are called frame but actually represent FrameSummary. This can be confusing and should be fixed at the same time where it doesn't break API.
title: confusion between frame and frame_summary in traceback module
Python tracker <report at bugs.python.org>
More information about the New-bugs-announce