[New-bugs-announce] [issue46401] Using setuptools version 59.8.0 or below before upgrade Python 3.10.2 from source on Debian 11

Ching report at bugs.python.org
Sun Jan 16 11:35:12 EST 2022


New submission from Ching <thus.kindly at gmail.com>:

1. Before upgrade to Python version 3.10.2 from source on Debian Linux, I must downgrade setuptools to version 59.8.0 or below.

2. At the stage of "make -j 4", setuptools version 60.0.0 or above raise an error of: ModuleNotFoundError: No module named 'binascii'

It is not a big issue, just remind Pythonistas to save their time to debug.

Reference of installation Python from source on Debian:
https://computingforgeeks.com/how-to-install-python-on-debian-linux/

----------
components: Installation
files: error1.txt
messages: 410701
nosy: i-Ching
priority: normal
severity: normal
status: open
title: Using setuptools version 59.8.0 or below before upgrade Python 3.10.2 from source on Debian 11
type: behavior
versions: Python 3.10
Added file: https://bugs.python.org/file50564/error1.txt

_______________________________________
Python tracker <report at bugs.python.org>
<https://bugs.python.org/issue46401>
_______________________________________


More information about the New-bugs-announce mailing list