[New-bugs-announce] [issue46950] Windows 11 venv

Darrel O'Pry report at bugs.python.org
Mon Mar 7 13:28:51 EST 2022

New submission from Darrel O'Pry <darrel.opry at spry-group.com>:

I created a virtual env on windows 11. 
When I run pip install -r "..."
I get the error 
C:\Users\dopry\src\Client\some.domain.com\django> pip install -r .\requirements_to_freeze.txt
Traceback (most recent call last):
  File "C:\Users\dopry\AppData\Local\Programs\Python\Python310\lib\runpy.py", line 196, in _run_module_as_main
    return _run_code(code, main_globals, None,
  File "C:\Users\dopry\AppData\Local\Programs\Python\Python310\lib\runpy.py", line 86, in _run_code
    exec(code, run_globals)
  File "C:\Users\dopry\src\Client\some.domain.com\django\venv310\Scripts\pip.exe\__main__.py", line 4, in <module>
ModuleNotFoundError: No module named 'pip'

When I run get command to verify that the venv is activated I get

(venv310) PS C:\Users\dopry\src\Client\some.domain.com\django> Get-Command python

CommandType     Name                                               Version    Source
-----------     ----                                               -------    ------
Application     python.exe                                         3.10.21... C:\Users\dopry\src\Client\some.domain.com\django\venv310\Scripts\python.exe

When I update the `venv310\pyenv.cfg` and set `include-system-site-packages = true` to true, it was defaulted to false, it seems that I can pip install my requirements successfully. 

When I try to start my app though, the requirements are not found.

components: Windows
messages: 414691
nosy: darrel.opry, paul.moore, steve.dower, tim.golden, zach.ware
priority: normal
severity: normal
status: open
title: Windows 11 venv
type: crash
versions: Python 3.10, Python 3.9

Python tracker <report at bugs.python.org>

More information about the New-bugs-announce mailing list