[Numpy-discussion] Trouble importing LinearAlgebra

crag wolfe crag at arsdigita.com
Tue Feb 27 04:03:24 EST 2001

Well, this a problem that is similar to the one discussed in the "Da
Blas" thread in September 2000.

My first command which works fine is "from Numeric import *".  The
problem is when I "import * from LinearAlgebra" I get "
Traceback (most recent call last):
  File "<stdin>", line 1, in ?
"/usr/local/lib/python2.0/site-packages/Numeric/LinearAlgebra.py", line
8, in ?
    import lapack_lite
ImportError: /usr/lib/liblapack.so.3: undefined symbol: e_wsfe"

I'm using Numeric-17.1.2.  I installed the lapack and blas rpms for Red
Hat 6.2, which I'm running.  I edited the setup.py file in the LALITE
directory as indicated.  I run "python setup_all.py install" which seems
to work fine (and I'm clearing out the build directories in between
install attempts).  "gcc -shared
build/temp.linux-i686-2.0/Src/lapack_litemodule.o -lblas -llapack -o
build/lib.linux-i686-2.0/lapack_lite.so" which scrolls by after running
the setup_all.py script, compiles without errors.

After the above failed, I tried manually running g77 in place of gcc (a
hint from the "Da Blas" thread) but then instead of the "undefined
symbol: e_wsfe" error I just get a seg fault.

Any help to get this package installed is much appreciated.

More information about the NumPy-Discussion mailing list