[Numpy-discussion] Problem with import ...

Todd Alan Pitts, Ph.D. tpitts at accentopto.com
Mon Sep 10 10:37:04 EDT 2001

In migrating from python 1.5.2 and Numeric 13 to python2.1.1 with
Numeric-20.1.0 I have encountered a rather pernicious problem.  I had
previously been using f2py 1.232 to generate modules for the BLAS and
a self-consistent subset of LAPACK.  Importing the thus created blas
and then lapack modules made their FORTRAN routines available to the
FORTRAN code that I had written.  Everything worked well.  However,
after I compiled python2.1.1 and Numeric-20.1.0 importing the blas and
lapack modules no longer provides access to their routines.  Moreover,
I can't even import the lapack module because it requires routines
from the blas module (that it can no longer see).  I get this behavior
on both RedHat 7.1 and 6.1 (e.g. with and without gcc 2.96).  I
verified that python2.2a behaves as 2.1.1 in this regard as well.  I
tried linking generating blas and lapack libraries and linking them
during creation of the shared libraries but that only worked
marginally.  I am still geting unresolved symbol errors.  Has anyone
else seen this problem/difference?  


More information about the NumPy-Discussion mailing list