[Numpy-discussion] numarray repackaging one more time...

Andrew P. Lentvorski, Jr. bsder at allcaps.org
Wed May 14 13:10:16 EDT 2003

On Wed, 14 May 2003, Todd Miller wrote:

> Point taken.   I guess that changes the addon mappings to:
> LinearAlgrebra2  --> numarray.linear_algebra
> FFT2             --> numarray.fft
> RandomArray2     --> numarray.random_array
> Convolve         --> numarray.convolve
> Convolve.Image   --> numarray.image
> MA2              --> numarray.ma

I prefer this naming scheme as it helps visually delineate between modules 
and classes. ie:

numarray.linear_algebra.LUMatrix is likely to be a class
numarray.linear_algebra.lumatrix is likely to be a module

It seems that most people use StudlyCaps for class names in Python.

While there aren't a lot of times that this matters, I have bumped into
this more often than I expect.  But I may just be doing odd things with 


More information about the NumPy-Discussion mailing list