[Numpy-discussion] Numpy-1.0.3 RPM install failure on SUSE 10.2

rex rex at nosyntax.com
Sat Jun 9 04:19:41 EDT 2007

David Cournapeau <david at ar.media.kyoto-u.ac.jp> [2007-06-08 22:49]:
> rex wrote:
> > I don't know if this is the appropriate place for this, but thanks for
> > any pointers to what the problem is.
> >
> > -rex
> >
> > Traceback (most recent call last):
> >   File "<stdin>", line 1, in <module>
> >   File "/usr/lib/python2.5/site-packages/numpy/__init__.py", line 43, in <module>
> >     import linalg
> >   File "/usr/lib/python2.5/site-packages/numpy/linalg/__init__.py", line 4, in <module>
> >     from linalg import *
> >   File "/usr/lib/python2.5/site-packages/numpy/linalg/linalg.py", line 25, in <module>
> >     from numpy.linalg import lapack_lite
> > ImportError: /usr/lib/libblas.so.3: undefined symbol: _gfortran_st_write_done
> >
> This is certainly because of a mismatch the compiler used for numpy and 
> blas/lapack. I checked the rpm you are using, and it looks like whereas 
> blas and lapack are compiled with gfortran, python-numpy is compiled 
> with g77. I do not use opensuse myself, but started a project to provide 
> binaries for numpy/scipy for this distribution: most of the packages 
> like blas and lapack are broken on this platform (I really wonder if 
> there was any testing of those packages by the packagers).
> The quickest thing would be to install numpy from sources. If you're 
> willing to help, I have some binary for numpy with my own blas/lapack 
> here, which need some feedback (and updating, too)
> http://software.opensuse.org/download/home:/ashigabou/openSUSE_10.2/

Thanks for the response. Numpy/SciPy has always been one of the most
difficult packages to install I've ever encountered (I've installed
hundreds of tarballs over the years). I've been using SUSE since version
6.4, and it's always a battle to get Numpy/SciPy running. I succeed
about every other release, but only after many hours of work. Half the
time I fail and don't use Numpy/SciPy until the next release. By then
I've forgotten the incredible frustration, and try again.

I tried to install from source with this result:

deserv:/usr/local/src/numpy-1.0.3 # python setup.py install
Running from numpy source directory.
Traceback (most recent call last):
  File "setup.py", line 91, in <module>
  File "setup.py", line 61, in setup_package
    from numpy.distutils.core import setup
  File "/usr/local/src/numpy-1.0.3/numpy/distutils/core.py", line 24, in <module>
    from numpy.distutils.command import build_ext
  File "/usr/local/src/numpy-1.0.3/numpy/distutils/command/build_ext.py", line 16, in <module>
    from numpy.distutils.system_info import combine_paths
  File "/usr/local/src/numpy-1.0.3/numpy/distutils/system_info.py", line 159, in <module>
    so_ext = distutils.sysconfig.get_config_vars('SO')[0] or ''
  File "/usr/lib/python2.5/distutils/sysconfig.py", line 493, in get_config_vars
  File "/usr/lib/python2.5/distutils/sysconfig.py", line 352, in _init_posix
    raise DistutilsPlatformError(my_msg)
distutils.errors.DistutilsPlatformError: invalid Python installation: unable to open /usr/lib/python2.5/config/Makefile (No such file or

There is no 'config' directory under /usr/lib/python2.5

There is a science repository linked from http://www.scipy.org/Installing_SciPy/Linux


I tried to install from the RPMs there, but the recursive dependency
chain broke when a gfortran lib that isn't there was required. I also
wonder if there was ANY testing by the packagers.


Times out. :( 

Again, thanks for the response. I think I'm going to go do something
more pleasant, like lay on a stinging ant nest...


More information about the NumPy-Discussion mailing list