[Numpy-discussion] segfault with dot

Matthieu Brucher matthieu.brucher at gmail.com
Sat Nov 17 06:05:46 EST 2007

What CPU do you have and which version of numpy did you get and where did
you get it from ?


2007/11/17, Jesus Torrecilla Pinero <jtorrecilla at gmail.com>:
> I am using Python 2.5.1 (r251:54863, Apr 18 2007, 08:51:08) under Windows
> XP and converting a program from Numeric to Numpy. If I have two arrays, say
> K and T and do dot(K,T) or K*T everything goes well, but if I have a vector
> b and try dot(K,b) or K*b I get a segfault.
> I have tried to run the test in tes_numeric.py and get the same result.
> I have tried too to convert b in a matrix with two columns, the second one
> being all zeroes, and numpy makes the multiplication correctly, so I think
> the problem is just with vectors
> Does this happens with other versions or do you have any idea to fix this
> problem?
> Thanks in advance
> --
> Jesús Torrecilla Pinero
> Universidad de Extremadura
> jtorrecilla at utcsl.com
> jtorreci at unex.es
> _______________________________________________
> Numpy-discussion mailing list
> Numpy-discussion at scipy.org
> http://projects.scipy.org/mailman/listinfo/numpy-discussion

French PhD student
Website : http://miles.developpez.com/
Blogs : http://matt.eifelle.com and http://blog.developpez.com/?blog=92
LinkedIn : http://www.linkedin.com/in/matthieubrucher
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.python.org/pipermail/numpy-discussion/attachments/20071117/2cbe62b5/attachment.html>

More information about the NumPy-Discussion mailing list