[Numpy-discussion] Plans for Numpy 1.4.0 and scipy 0.8.0

Stéfan van der Walt stefan at sun.ac.za
Mon Jun 22 02:56:30 EDT 2009


2009/6/22 David Cournapeau <cournape at gmail.com>:
> My main motivation for an early numpy 1.4 is scipy 0.8.0. But if other
> people think numpy 1.4.0 as it is now is too 'weak', making scipy
> 0.8.0 compatible with numpy 1.3.0 is technically possible. Then we can
> talk about adding those features for numpy 1.4.0, and release it
> later.

I think there are enough changes for a 1.4 release.  It makes little
sense to put our effort into making SciPy compatible with an old
version of NumPy, rather than moving both packages forward.

Regards
Stéfan



More information about the NumPy-Discussion mailing list