[Numpy-discussion] (apparent) infinite loop in LAPACK/ATLAS

David Warde-Farley dwf at cs.toronto.edu
Wed Nov 4 00:55:33 EST 2009

Hi all (mostly David C. since he probably knows all this horrible  

I noticed on my new laptop (with an Atom N280 in it) that when I run  
numpy.test() about the 34th test would loop, seemingly forever.

Finding this a little odd, I tried an SVD on a small matrix and  
observed the same behaviour, narrowed it down with gdb to what seems  
to be an infinite loop involving dlamc1_ and dlamc3_, which I gather  
are routines for converting from row-major to column-major. I should  
mention that I built ATLAS (3.9.7, because that's the tarball I had  
around) and LAPACK (3.1.1) from source.  Oh, and this is on Ubuntu  
9.10, Karmic Koala, using gcc 4.4.1 (with the exception of the ATLAS  
kernels which are using gcc 4.2.4 for the reasons stated in the  
install document).

I came upon this mention of a similar problem ( https://projects.coin-or.org/BuildTools/ticket/66 
  ), so far. I'm going to try using the flag they suggest but it'll be  
a while before I have a verdict on whether it's fixed or not, so I'm  
soliciting any other ideas as to the cause of/solution to such an issue.

Thanks in advance,


More information about the NumPy-Discussion mailing list