[Numpy-discussion] Python 2.6, NumPy on CentOS 5.3

Robert DeLisle rkdelisle at gmail.com
Tue Nov 24 12:11:42 EST 2009

David Cournapeau wrote:

You need the *.so and not the *.so.3.1.1. The latter are enough to *run*
applications linked against the library, the former is necessary to link
against them. IOW, you need the devel packages for blas, lapack (and
python). If you want to do it without admin rights, there is no other
solution than building them by yourself.


Thank you so much!  That helps a lot and I don't know why I didn't think of
it myself.  As root I'm able to install blas-devel and lapack-devel which
gives me new libraries in /usr/lib64.  Specifically, libblas.a, liblapack.a,
and liblapack_pic.a.  Now when I run setup.py from the numpy directory, it
says that it finds the libraries in the appropriate locations.

A few more issues:

The configuration complains that there are no mkl, vml, guide libraries.
Also, atlas libraries are not found.  I cannot seem to find these at this

The configuration also complains about no Fortran 90 compiler.  I do have
f77 and f95 as part of the GCC package.  Is this enough.

The build and install step seems to go OK despite the above warnings but
then it fails with the error could not create /usr/lib/python2.6.  So, I did
an in place build and I see some libraries in the /build directory but there
is no python2.6 file that I can find.  What are the steps that I need to
take in order to manually install these, and which libraries should I be
paying attention to?

Just to clarify, I'm running this NOT as root in order to be able to use
Python 2.6.  I have installed Python 2.6 under /opt/Python_2.6.4 and
adjusted my own environment variables to target the appropriate version.
(This should keep CentOS from breaking by retaining the system python,
v.2.4.3.)  I've also made the /opt/Python_2.6.4 directory writable by my
user account to facilitate automated steps.

Any help you can supply is very greatly appreciated.


On Tue, Nov 24, 2009 at 9:33 AM, Gökhan Sever <gokhansever at gmail.com> wrote:

> On Mon, Nov 23, 2009 at 7:07 PM, <rkdelisle at gmail.com> wrote:
>> An application package that I have requires Python 2.6 and NumPy.
>> I've installed Python 2.6 in a parallel manner as follows:
>> NO modification of the core Python2.4 in /usr/bin has been done. Rather, I
>> installed Python 2.6 under /opt/Python_2.6.4 and modified my user (not root)
>> environment variables appropriately. The directory /opt/Python_2.6.4 was
>> modified with chown to give me rwx access.
>> To install NumPy, I've downloaded the latest .tgz sources (v1.3.0) to
>> build. When I attempt to configure/build I receive various errors related to
>> blas and lapack. The NumPy configuration is searching /usr/lib, /usr/lib64,
>> /usr/local/lib, and /usr/local/lib64 for various blas, lapack, and atlas
>> libraries. Within /usr/lib64 I do find a few lapack and blas and lapack
>> libraries installed (libblas.so.3.1.1 and liblapack.so.3.1.1), but configure
>> is not finding them. No atlas libraries are found, but my understanding is
>> that these are deprecated anyway.
>> As an alternative, I tried to install NumPy using the standard Python
>> 2.4.3 using yum install NumPy but I receive an error saying that NumPy is
>> obsoleted by PyNumeric. What?? PyNumeric is the precursor to NumPy. So even
>> in the most basic instance, I cannot install NumPy because a deprecated
>> library is seen as higher priority? Even given the generally out of date
>> nature of CentOS this is unrealistic.
>> Finally, I could try to build blas and lapack myself, but this seems to
>> border on insanity.
>> Any help is appreciated.
>> -Kirk
> I had success installing NumPy 1.3 to two of our RHEL 5.x (x86) machines
> using the pre-built packages from this repository:
> http://download.opensuse.org/repositories/home:/ashigabou/CentOS_5/
> RHEL 5.x serie has Python 2.4.3 by default as you mentioned. Installation
> of NumPy et. al is far easier in Fedora (mine is still at version 11) from
> the source check-out plus manual installation of dependencies. I haven't
> tried installing a Python 2.6.x to RHEL machines. I would like to see an
> update from if you succeed with the mentioned repository.
>> _______________________________________________
>> NumPy-Discussion mailing list
>> NumPy-Discussion at scipy.org
>> http://mail.scipy.org/mailman/listinfo/numpy-discussion
> --
> Gökhan
> _______________________________________________
> NumPy-Discussion mailing list
> NumPy-Discussion at scipy.org
> http://mail.scipy.org/mailman/listinfo/numpy-discussion
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.python.org/pipermail/numpy-discussion/attachments/20091124/eeb7d0b5/attachment.html>

More information about the NumPy-Discussion mailing list