[Numpy-discussion] Python 2.6, NumPy on CentOS 5.3

Robert DeLisle rkdelisle at gmail.com
Tue Nov 24 12:13:44 EST 2009


Thank you for the referred repo.  I'll keep this as a reference for future
endeavours should I fail given my current approach.  As for installing
Python 2.6.4, that was very easily done as a parallel installation as I
described.  I'm more than happy to give you more details if you need them.


On Tue, Nov 24, 2009 at 9:33 AM, Gökhan Sever <gokhansever at gmail.com> wrote:

> On Mon, Nov 23, 2009 at 7:07 PM, <rkdelisle at gmail.com> wrote:
>> An application package that I have requires Python 2.6 and NumPy.
>> I've installed Python 2.6 in a parallel manner as follows:
>> NO modification of the core Python2.4 in /usr/bin has been done. Rather, I
>> installed Python 2.6 under /opt/Python_2.6.4 and modified my user (not root)
>> environment variables appropriately. The directory /opt/Python_2.6.4 was
>> modified with chown to give me rwx access.
>> To install NumPy, I've downloaded the latest .tgz sources (v1.3.0) to
>> build. When I attempt to configure/build I receive various errors related to
>> blas and lapack. The NumPy configuration is searching /usr/lib, /usr/lib64,
>> /usr/local/lib, and /usr/local/lib64 for various blas, lapack, and atlas
>> libraries. Within /usr/lib64 I do find a few lapack and blas and lapack
>> libraries installed (libblas.so.3.1.1 and liblapack.so.3.1.1), but configure
>> is not finding them. No atlas libraries are found, but my understanding is
>> that these are deprecated anyway.
>> As an alternative, I tried to install NumPy using the standard Python
>> 2.4.3 using yum install NumPy but I receive an error saying that NumPy is
>> obsoleted by PyNumeric. What?? PyNumeric is the precursor to NumPy. So even
>> in the most basic instance, I cannot install NumPy because a deprecated
>> library is seen as higher priority? Even given the generally out of date
>> nature of CentOS this is unrealistic.
>> Finally, I could try to build blas and lapack myself, but this seems to
>> border on insanity.
>> Any help is appreciated.
>> -Kirk
> I had success installing NumPy 1.3 to two of our RHEL 5.x (x86) machines
> using the pre-built packages from this repository:
> http://download.opensuse.org/repositories/home:/ashigabou/CentOS_5/
> RHEL 5.x serie has Python 2.4.3 by default as you mentioned. Installation
> of NumPy et. al is far easier in Fedora (mine is still at version 11) from
> the source check-out plus manual installation of dependencies. I haven't
> tried installing a Python 2.6.x to RHEL machines. I would like to see an
> update from if you succeed with the mentioned repository.
>> _______________________________________________
>> NumPy-Discussion mailing list
>> NumPy-Discussion at scipy.org
>> http://mail.scipy.org/mailman/listinfo/numpy-discussion
> --
> Gökhan
> _______________________________________________
> NumPy-Discussion mailing list
> NumPy-Discussion at scipy.org
> http://mail.scipy.org/mailman/listinfo/numpy-discussion
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.python.org/pipermail/numpy-discussion/attachments/20091124/6c485d36/attachment.html>

More information about the NumPy-Discussion mailing list