[Numpy-discussion] Packaging numpy with py2app v0.4.3

Christopher Barker Chris.Barker at noaa.gov
Mon Nov 30 16:29:22 EST 2009

Donovan Parks wrote:

I think this may have nothing at all to do with numpy. Have you tried a 
simple script that doesn't use numpy?
> OS X Leopard
> MacPort

I use neither Leopard nor macports, so it may be an issue there, but 
with the python.org python25 and numpy1.3, I have no problems.

> When I run 'python setup.py py2app' I get the following error after
> py2app starts stripping out debug information:
> /usr/bin/strip: for architecture i386 object:
> /Users/dparks/test/dist/numpyTest.app/Contents/Frameworks/libgcc_s.1.dylib
> truncated or malformed object (LC_SEGMENT command 2 fileoff field plus

note that this is a libgcc error -- you wouldn't need libgcc if you used 
the python.org build...

> ZipImportError: can't decompress data; zlib not available

> I tried --no-strip which does cause a clean 'build' from py2app,

I don't think this has anything to do with the stripping (or numpy). 
py2app, by default, puts all the modules you need into a zipped archive, 
so any import you do is going to be a problem if zlib is not available.

I suspect this may be a macports/py2app incompatibility -- with the 
python.org python, it probably uses a system zlib, so it hasn't bundled 
up zlib from macports for you.

I'd try asking on the pythonmac list.


Christopher Barker, Ph.D.

Emergency Response Division
NOAA/NOS/OR&R            (206) 526-6959   voice
7600 Sand Point Way NE   (206) 526-6329   fax
Seattle, WA  98115       (206) 526-6317   main reception

Chris.Barker at noaa.gov

More information about the NumPy-Discussion mailing list