[Numpy-discussion] problem with applying patch

z99719 z99719 z99719 at gmail.com
Sat Mar 13 14:06:24 EST 2010

I have installed latest numpy from svn on ubuntu karmic(9.10) and compiled
the code in my sand box. I downloaded two patches
(test_umath_complex.py.patch, build_clib.py.patch) from the review patch
directory on http://projects.scipy.org/numpy/report/12 page for testing. The
following patch command gives me

patch -p0 -i test_umath_complex.py.patch
patch unexpectedly ends in middle of line
patch: **** Only garbage was found in the patch input.

The patch files are placed in the top level numpy sandbox directory and are
in xml format rather than a diff file. I used "save link as" on the link to
download the patch on the "Attachments" section of the link page.
Checked the test_umath_complex.py in the numpy/core/test directory and found
significant differences with the listing on the patch link (both old, and
the new versions).

Don't think this is limited to just these patches any patch that I tried
gives the same error message.

Thank you
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.python.org/pipermail/numpy-discussion/attachments/20100313/7b55b66e/attachment.html>

More information about the NumPy-Discussion mailing list