[Numpy-discussion] Problem installing NumPy with Python 3.2.2/MacOS X 10.7.2

Ralf Gommers ralf.gommers at googlemail.com
Sun Dec 18 03:49:00 EST 2011


On Sat, Dec 17, 2011 at 12:59 PM, McNicol, Adam <amcnicol at longroad.ac.uk>wrote:

> **
>
> Hi There,
>
> Thanks for the responses.
>
> At this point I would settle from just being able to install matplotlib.
> Even if some of the functionality isn't present currently that is fine.
>
> I'm afraid my knowledge of Python falls down about here as well. I
> installed Python 3.2.2 via the installer from Python.org so I have no idea
> whether Python.h is present or where indeed I would find it or how I would
> add it to the search path.
>
> Do I have to install from source or something like that?
>

No, your Python install should be fine if you just got the dmg installer
from python.org. I recommend you install the OS X SDKs and distribute (
http://pypi.python.org/pypi/distribute), as I said before, and try again to
compile numpy.

Unfortunately you have chosen a difficult combination of OS and Python
version, so we don't have binary installers you can use (yet).

Ralf


> Thanks again,
>
>
> Adam.
>
>
> -----Original Message-----
> From: McNicol, Adam
> Sent: Fri 12/16/2011 11:07 PM
> To: numpy-discussion at scipy.org
> Subject: Problem installing NumPy with Python 3.2.2/MacOS X 10.7.2
>
> Hi There,
>
> I am very new to numpy and have really only started investigating it as
> one of my students needs some functionality from matplotlib. I have managed
> to install everything under Windows for work in class but I use a Mac at
> home and have been struggling all night to get it to build and install.
>
> I should mention that I am using Python 3.2.2 both in school and at home
> and it isn't an option to use Python 2.7 as all of the rest of my class is
> taught in Python 3. I also have the most recent version of Xcode installed.
>
> I have installed the correct build of gcc-4.2 with Fortran (gcc-4.2 (Apple
> build 5666.3) with GNU Fortran 4.2.4 for Mac OS X 10.7 (Lion)) from
> http://r.research.att.com/tools/
>
> I then followed the install instructions but the build fails with the
> following message:
>
>   File "numpy/core/setup.py", line 271, in check_types
>     "Cannot compile 'Python.h'. Perhaps you need to "\
> SystemError: Cannot compile 'Python.h'. Perhaps you need to install
> python-dev|python-devel.
>
> I have got no idea what to do with this error message. Any help would be
> much appreciated.
>
> Kind Regards,
>
>
> Adam.
>
>
> _______________________________________________
> NumPy-Discussion mailing list
> NumPy-Discussion at scipy.org
> http://mail.scipy.org/mailman/listinfo/numpy-discussion
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.python.org/pipermail/numpy-discussion/attachments/20111218/0747fb12/attachment.html>


More information about the NumPy-Discussion mailing list