[Numpy-discussion] installing matplotlib in MacOs 10.6.8.

Alex Ter-Sarkissov ater1980 at gmail.com
Mon Dec 26 00:40:56 EST 2011

hi everyone, I run python 2.7.2. in Eclipse (recently upgraded from 2.6). I
have a problem with installing matplotlib (I found the version for python
2.7. MacOs 10.3, no later versions). If I run python in terminal using arch
-i386 python, and then

from matplotlib.pylab import *

and similar stuff, everything works fine. If I run python in eclipse or
just without arch -i386, I can import matplotlib as

from matplotlib import  *

but actually nothing gets imported. If I do it in the same way as above, I
get the message

no matching architecture in universal wrapper

which means there's conflict of versions or something like that. I tried
reinstalling the interpreter and adding matplotlib to forced built-ins, but
nothing helped. For some reason I didn't have this problem with numpy and

Any suggestions are appreciated.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.python.org/pipermail/numpy-discussion/attachments/20111226/5b24c575/attachment.html>

More information about the NumPy-Discussion mailing list