[Numpy-discussion] installing matplotlib in MacOs 10.6.8.

Chris Barker chris.barker at noaa.gov
Tue Dec 27 16:34:09 EST 2011


I suspect your getting a bit tangled up in the multiple binaries of
Python on the Mac.

On the python.org site there are two binaries:

32bit, PPC_Intel, OS-X 10.3.9 and above.

32 and 64 bit, Intel only, OS-X 10.6 and above.

You need to make sure that you get a matplotlib build for the python
build you are using.

It looks like the current "official" binaries for MPL only support the
32bit PPC+Intel version:

http://sourceforge.net/projects/matplotlib/files/matplotlib/matplotlib-1.1.0/

If you use that (the 32 bit binary form pyton.org and the 32 bit MPL
binary), you should be fine. If you need 64 bit, it looks like you are
on your own for building (sigh).

> If I run python in terminal using arch
> -i386 python, and then
>
> from matplotlib.pylab import *
>
> and similar stuff, everything works fine.

I suspect you have the 32-64bit Intel python build -- the 32 bit Intel
part overlaps

> If I run python in eclipse or just
> without arch -i386, I can import matplotlib as
>
> from matplotlib import  *
>
> but actually nothing gets imported. If I do it in the same way as above, I
> get the message
>
> no matching architecture in universal wrapper

you are probably running 64 bit by default, which would explain that
-- MPL is there, but there is no 64 bit Intel binary in the bundle.

> Any suggestions are appreciated.

Install the 32 bit binary from python.org -- or you could probably get
away with telling eclipe to pass the arch flag when it runs python --
but that feels ugly to me!

-Chris


-- 
--

Christopher Barker, Ph.D.
Oceanographer

Emergency Response Division
NOAA/NOS/OR&R            (206) 526-6959   voice
7600 Sand Point Way NE   (206) 526-6329   fax
Seattle, WA  98115       (206) 526-6317   main reception

Chris.Barker at noaa.gov



More information about the NumPy-Discussion mailing list