[Numpy-discussion] mkl 10.3 linking - undefined symbol: i_free?

Andrzej Giniewicz gginiu at gmail.com
Sun Feb 13 09:01:34 EST 2011


I'd like to ask if anyone got around the undefined symbol i_free
issue? What I did was that I used link advisor from
file:///home/giniu/Downloads/MKL_Linking_Adviser-1.03.htm and it told
me to use

-L$MKLPATH $MKLPATH/libmkl_solver_lp64.a -Wl,--start-group
-lmkl_gf_lp64 -lmkl_gnu_thread -lmkl_core -Wl,--end-group -fopenmp

So I created site.cfg like:

library_dirs = /opt/intel/composerxe-2011.2.137/mkl/lib/intel64
include_dirs = /opt/intel/composerxe-2011.2.137/mkl/include
mkl_libs = mkl_gf_lp64, mkl_gnu_thread, mkl_core
lapack_libs = mkl_lapack95_lp64

and added -fopenmp to LDFLAGS. Numpy built, then I was able to
install. I started python and imported numpy, and till this point it
worked. When I tried to run numpy.test() and got:

Running unit tests for numpy
NumPy version 1.5.1
NumPy is installed in /usr/lib/python2.7/site-packages/numpy
Python version 2.7.1 (r271:86832, Feb  7 2011, 19:39:54) [GCC 4.5.2
20110127 (prerelease)]
nose version 1.0.0

*** libmkl_def.so *** failed with error :
undefined symbol: i_free
MKL FATAL ERROR: Cannot load libmkl_def.so

Anyone who got this working could give me some hint about how to get
around it? I would be grateful


More information about the NumPy-Discussion mailing list