[Numpy-discussion] compatibility for supporting more than 2 versions of numpy

josef.pktd at gmail.com josef.pktd at gmail.com
Mon Jan 17 11:28:56 EST 2011


On Sat, Jan 15, 2011 at 3:27 PM,  <josef.pktd at gmail.com> wrote:
> After upgrading to numpy 1.5.1 I got caught by some depreciated
> features. Given the depreciation policy of numpy, if we want to
> support more than two versions of numpy, then we need some conditional
> execution.
>
> Does anyone have any compatibility functions?
>
> I haven't looked at it carefully yet, but statsmodels might need
> things like the following if we want to support numpy 1.3
>
>    if np.__version__ < '1.5':
>        freq,hsupp = np.histogram(rvs, histsupp, new=True)
>    else:
>        freq,hsupp = np.histogram(rvs,histsupp)
>
> matplotlib says it supports numpy >=1.1 but I didn't see any
> compatibility code that I could "borrow".
> Or do I worry for nothing? The compatibility.py in statsmodels is
> still almost empty.


for scipy.linalg, in numdifftools, I changed this in core (in my copy)

        if numpy.__version__ < '1.5':
            [qromb,rromb] = linalg.qr(rmat, econ=True)
        else:
            [qromb,rromb] = linalg.qr(rmat, mode='economic')


>
> Josef
>



More information about the NumPy-Discussion mailing list