[Numpy-discussion] Broken numpy install

Ralf Gommers ralf.gommers at googlemail.com
Sat May 21 06:54:51 EDT 2011

On Sat, May 21, 2011 at 12:40 PM, Milan Mitrovic <milan.v.mitrovic at gmail.com
> wrote:

> Hello everyone,
> I have a problem with my numpy installation. I installed numpy, scipy
> and matplotlib from source, about one year ago (the macports install
> wouldn't work for me). This worked fine untill I had some problems two
> days ago (as it later turned out, completely unrelated to numpy) but
> my thesis advisor suggested that I update numpy and scipy. Since then
> I've been trying to make it work (and haven't worked on my thesis at
> all).

The reason for this is that you recompiled numpy but not matplotlib. You can
either use numpy 1.6.0, which will work with the matplotlib you compiled
earlier. Or you have to recompile matplotlib against your current numpy (not
always easy on OS X). There are also up-to-date binary installers for
numpy/scipy/mpl you can use.


> So, I updated the git/svn code to the latest versions, re-ran build
> and install and things don't work any more. I have a script that I am
> trying to use and here is the error message that I get:
> RuntimeError: module compiled against ABI version 1000009 but this
> version of numpy is 2000000
> Traceback (most recent call last):
>  File "../ppm/libppm/utils/ppm_dbg/ppmdbg.py", line 2, in <module>
>    from mpl_toolkits.mplot3d import Axes3D
>  File
> "/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/mpl_toolkits/mplot3d/__init__.py",
> line 1, in <module>
>    from axes3d import Axes3D
>  File
> "/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/mpl_toolkits/mplot3d/axes3d.py",
> line 13, in <module>
>    from matplotlib.axes import Axes, rcParams
>  File
> "/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/matplotlib/axes.py",
> line 12, in <module>
>    import matplotlib.artist as martist
>  File
> "/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/matplotlib/artist.py",
> line 6, in <module>
>    from transforms import Bbox, IdentityTransform, TransformedBbox,
> TransformedPath
>  File
> "/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/matplotlib/transforms.py",
> line 34, in <module>
>    from matplotlib._path import affine_transform
> ImportError: numpy.core.multiarray failed to import
> I have tried googling and followed every piece of advice I could find.
> Nothing worked. Please let me know what info I need to provide so you
> can help me. Or tell me a way to completely clean my system and start
> all over (cause it seems that it is being built for the wrong python).
> Btw, some people on #scipy on freenode suggested that I try running
> the script with all interpreters I get from which -a python... they
> all failed with the same error message.
> Thanks in advance,
> Milan Mitrovic
> _______________________________________________
> NumPy-Discussion mailing list
> NumPy-Discussion at scipy.org
> http://mail.scipy.org/mailman/listinfo/numpy-discussion
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.python.org/pipermail/numpy-discussion/attachments/20110521/7c69e57f/attachment.html>

More information about the NumPy-Discussion mailing list