[Numpy-discussion] Runtime error in numpy development version

Kathleen M Tacina Kathleen.M.Tacina at nasa.gov
Tue May 24 19:22:33 EDT 2011


I get the following runtime error when I import numpy: "module compiled
against ABI version 2000000 but this version of numpy is 1000009" (see
below).

Python 2.7.1 (r271:86832, May 20 2011, 14:41:42)
[GCC 4.4.0 20090514 (Red Hat 4.4.0-6)] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> import numpy as np
RuntimeError: module compiled against ABI version 2000000 but this
version of numpy is 1000009
>>> np.version.version
'2.0.0.dev-3071eab'
>>>     

This error doesn't seem to effect the operation of numpy  --- most tests
in np.test('full') pass and most of the numpy functions I used regularly
work --- but it causes the import of opencv to fail.

>>> import cv
RuntimeError: module compiled against ABI version 2000000 but this
version of numpy is 1000009
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
ImportError: numpy.core.multiarray failed to import
>>> import numpy.core.multiarray
>>> numpy.core.multiarray.arange(5)
array([0, 1, 2, 3, 4])
>>>   
           
Thanks for any help you can give me with this.

Kathy

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.python.org/pipermail/numpy-discussion/attachments/20110524/d5c5dfd4/attachment.html>


More information about the NumPy-Discussion mailing list