[Numpy-discussion] f2py : NotImplementedError: Only MS compiler supported with gfortran on win64

"V. Armando Solé" sole at esrf.fr
Thu Sep 8 12:44:29 EDT 2011

On 08/09/2011 16:16, Jim Vickroy wrote:
> On 9/8/2011 6:09 AM, "V. Armando Solé" wrote:
>> Have you tried to install Visual Studio 2008 Express edition (plus the
>> windows SDK to be able to compile 64 bit code)?
>> Armando
> Armando, "Visual Studio 2008 Professional" is installed on the computer
> as well as "Intel Visual Fortran Composer XE 2011".
> f2py was not finding the Intel compiler (f2py -c --help-fcompiler) so I
> tried gfortran.
> The "Win64" reference, in the Exception, is puzzling to me since this is
> a 32-bit computer.

Oh! I totally misunderstood the situation. I thought the problem was the 
missing compiler.

All what I do with python and the intel fortran compiler is to compile 
numpy. Just in case it helps you, I set my environment from the console 
by running a bat file with the following content (I am on 64 bit but you 
could easily tailor it to your needs):

"C:\Program Files\Microsoft SDKs\Windows\v7.0\Setup\WindowsSdkVer.exe" 
call "C:\Program Files (x86)\Microsoft Visual Studio 
call "C:\Program Files 
(x86)\Intel\ComposerXE-2011\bin\ipsxe-comp-vars.bat" intel64 vs2008shell
rem call "C:\Program Files (x86)\Microsoft Visual Studio 
rem call "C:\Program Files\Microsoft SDKs\Windows\v7.0\Bin\setenv.cmd" 
/x64 /Release
set PATH=C:\Python27;C:\Python27\Scripts;%PATH%
set PATH="C:\Program Files 
(x86)\Intel\ComposerXE-2011\redist\intel64\mkl";"C:\Program Files 

Perhaps that helps you to set a working environment. All what I can tell 
you is that with that environment, if I run "python f2py.py -c 
--help-fcompiler" it finds the intel compiler.

Good luck,


More information about the NumPy-Discussion mailing list