[Numpy-discussion] installing matplotlib in MacOs 10.6.8.

Samuel John scipy at samueljohn.de
Tue Jan 24 18:06:08 EST 2012

Sorry for the late answer. But at least for the record:

If you are using eclipse, I assume you have also installed the eclipse plugin [pydev](http://pydev.org/). Is use it myself, it's good. 
Then you have to go to the preferences->pydev->PythonInterpreter and select the python version you want to use by searching for the "Python" executable. 

I am not familiar with the pre-built versions of matplotlib. Perhaps they miss the 64bit intel versions? 
Perhaps you can find a lib (.so file) in matplotlib and use the "file" command to see the architectures, it was built for.
You should be able to install matplotlib also with `pip install matplotlib`. (if you have pip)


On 26.12.2011, at 06:40, Alex Ter-Sarkissov wrote:

> hi everyone, I run python 2.7.2. in Eclipse (recently upgraded from 2.6). I have a problem with installing matplotlib (I found the version for python 2.7. MacOs 10.3, no later versions). If I run python in terminal using arch -i386 python, and then 
> from matplotlib.pylab import *
> and similar stuff, everything works fine. If I run python in eclipse or just without arch -i386, I can import matplotlib as 
> from matplotlib import  *
> but actually nothing gets imported. If I do it in the same way as above, I get the message
> no matching architecture in universal wrapper
> which means there's conflict of versions or something like that. I tried reinstalling the interpreter and adding matplotlib to forced built-ins, but nothing helped. For some reason I didn't have this problem with numpy and tkinter. 
> Any suggestions are appreciated. 
> _______________________________________________
> NumPy-Discussion mailing list
> NumPy-Discussion at scipy.org
> http://mail.scipy.org/mailman/listinfo/numpy-discussion

More information about the NumPy-Discussion mailing list