[Numpy-discussion] Created NumPy 1.7.x branch

Fernando Perez fperez.net at gmail.com
Tue Jun 26 01:09:04 EDT 2012


On Mon, Jun 25, 2012 at 9:48 PM, Travis Oliphant <travis at continuum.io> wrote:
> I agree a decision needs to be made.   I think we will need to break the ABI.    At this point, I don't know of any pressing features that would require it short of NumPy 2.0.

Sorry, I don't quite know how to parse the above, do you mean:

1. We will need to break ABI in the upcoming 1.7 release

or

2. We will need to be more willing to accept ABI breakages in .Y
releases (in X.Y convention)

Just curious...

Cheers,

f



More information about the NumPy-Discussion mailing list