[Numpy-discussion] Dropping support for Python 2.4 in NumPy 1.8
ralf.gommers at googlemail.com
Thu Jun 28 11:08:36 EDT 2012
On Thu, Jun 28, 2012 at 4:44 PM, Olivier Delalleau <shish at keba.be> wrote:
> 2012/6/28 David Cournapeau <cournape at gmail.com>
>> Hi Travis,
>> On Thu, Jun 28, 2012 at 1:25 PM, Travis Oliphant <travis at continuum.io>
>> > Hey all,
>> > I'd like to propose dropping support for Python 2.4 in NumPy 1.8 (not
>> the 1.7 release). What does everyone think of that?
>> I think it would depend on 1.7 state. I am unwilling to drop support
>> for 2.4 in 1.8 unless we make 1.7 a LTS, that would be supported up to
>> 2014 Q1 (when RHEL5 stops getting security fixes - RHEL 5 is the one
>> platform that warrants supporting 2.4 IMO)
>> In my mind, it means 1.7 needs to be stable. Ondrej (and others) work
>> to make sure we break neither API or ABI since a few releases would
>> help achieving that.
> As a user stuck with Python 2.4 for an undefined period of time, I would
> definitely appreciate a long-term support release that would retain Python
> 2.4 compatibility.
Hi, I have an honest question for you (and other 2.4 users). Many packages
have long since dropped 2.4 compatibility. IPython and scikit-learn require
2.6 as a minimum, scikits-image and statsmodels 2.5. So what do you do
about those packages, not use them at all, or use an older version?
All those packages are improving (in my opinion) at a much faster rate than
numpy. So if you do use them, up-to-date versions of those are likely to be
more useful than a new version of numpy. In that light, does keeping 2.4
support really add significant value for you?
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the NumPy-Discussion