[Numpy-discussion] Mysterious test_pareto failure on Travis

Scott Sinclair scott.sinclair.za at gmail.com
Tue Sep 4 08:47:57 EDT 2012

On 4 September 2012 12:23, Matthew Brett <matthew.brett at gmail.com> wrote:
> On Tue, Sep 4, 2012 at 11:15 AM, Nathaniel Smith <njs at pobox.com> wrote:
>> The last two Travis builds of master have failed consistently with the
>> same error:
>>   http://travis-ci.org/#!/numpy/numpy/builds
>> It looks like a real failure -- we're getting the same error on every
>> build variant, some sort of problem in test_pareto. Example:
>>   http://travis-ci.org/#!/numpy/numpy/jobs/2328823
>> The obvious culprit would be the previous commit, which regenerated
>> mtrand.c with Cython 0.17:
>>   http://github.com/numpy/numpy/commit/cd9092aa71d23359b33e89d938c55fb14b9bf606
>> What's weird, though, is that that commit passed just fine on Travis:
>>   http://travis-ci.org/#!/numpy/numpy/builds/2313124
>> It's just the two commits since then that failed. But these commits
>> have been 1-line docstring changes, so I don't see how they could have
>> possibly created the problem.
>> Also, the test passes fine with python 2.7 on my laptop with current master.
>> Can anyone reproduce this failure? Any ideas what might be going on?
> I believe Travis just (a couple of days ago?) switched to Ubuntu 12.04
> images - could that be the problem?

For whatever it's worth, tox reports:

  py24: commands succeeded
  py25: commands succeeded
  py26: commands succeeded
  py27: commands succeeded
ERROR:   py31: InterpreterNotFound: python3.1
  py32: commands succeeded
  py27-separate: commands succeeded
  py32-separate: commands succeeded

with git revision a72ce7e on my Ubuntu 12.04 machine (64-bit).


More information about the NumPy-Discussion mailing list