[Numpy-discussion] Mysterious test_pareto failure on Travis

Ondřej Čertík ondrej.certik at gmail.com
Tue Sep 4 15:41:57 EDT 2012

On Tue, Sep 4, 2012 at 12:31 PM, Ondřej Čertík <ondrej.certik at gmail.com> wrote:
> On Tue, Sep 4, 2012 at 3:15 AM, Nathaniel Smith <njs at pobox.com> wrote:
>> The last two Travis builds of master have failed consistently with the
>> same error:
>>   http://travis-ci.org/#!/numpy/numpy/builds
>> It looks like a real failure -- we're getting the same error on every
>> build variant, some sort of problem in test_pareto. Example:
>>   http://travis-ci.org/#!/numpy/numpy/jobs/2328823
>> The obvious culprit would be the previous commit, which regenerated
>> mtrand.c with Cython 0.17:
>>   http://github.com/numpy/numpy/commit/cd9092aa71d23359b33e89d938c55fb14b9bf606
>> What's weird, though, is that that commit passed just fine on Travis:
>>   http://travis-ci.org/#!/numpy/numpy/builds/2313124
>> It's just the two commits since then that failed. But these commits
>> have been 1-line docstring changes, so I don't see how they could have
>> possibly created the problem.
>> Also, the test passes fine with python 2.7 on my laptop with current master.
>> Can anyone reproduce this failure? Any ideas what might be going on?
> I made this:
> https://github.com/numpy/numpy/issues/424
> It was me who updated the Cython file. It seemed to be working. I've
> added the issue
> to the release TODO.

Ok, here is how to reproduce the problem:

1) install my numpy-vendor vagrant image (32 bit Ubuntu), as directed
in the README:


2) run tests, you'll get:



More information about the NumPy-Discussion mailing list