[Numpy-discussion] Mysterious test_pareto failure on Travis

Ondřej Čertík ondrej.certik at gmail.com
Tue Sep 4 16:17:39 EDT 2012

On Tue, Sep 4, 2012 at 12:41 PM, Ondřej Čertík <ondrej.certik at gmail.com> wrote:
> On Tue, Sep 4, 2012 at 12:31 PM, Ondřej Čertík <ondrej.certik at gmail.com> wrote:
>> On Tue, Sep 4, 2012 at 3:15 AM, Nathaniel Smith <njs at pobox.com> wrote:
>>> The last two Travis builds of master have failed consistently with the
>>> same error:
>>>   http://travis-ci.org/#!/numpy/numpy/builds
>>> It looks like a real failure -- we're getting the same error on every
>>> build variant, some sort of problem in test_pareto. Example:
>>>   http://travis-ci.org/#!/numpy/numpy/jobs/2328823
>>> The obvious culprit would be the previous commit, which regenerated
>>> mtrand.c with Cython 0.17:
>>>   http://github.com/numpy/numpy/commit/cd9092aa71d23359b33e89d938c55fb14b9bf606
>>> What's weird, though, is that that commit passed just fine on Travis:
>>>   http://travis-ci.org/#!/numpy/numpy/builds/2313124
>>> It's just the two commits since then that failed. But these commits
>>> have been 1-line docstring changes, so I don't see how they could have
>>> possibly created the problem.
>>> Also, the test passes fine with python 2.7 on my laptop with current master.
>>> Can anyone reproduce this failure? Any ideas what might be going on?
>> I made this:
>> https://github.com/numpy/numpy/issues/424
>> It was me who updated the Cython file. It seemed to be working. I've
>> added the issue
>> to the release TODO.
> Ok, here is how to reproduce the problem:
> 1) install my numpy-vendor vagrant image (32 bit Ubuntu), as directed
> in the README:
> https://github.com/certik/numpy-vendor
> 2) run tests, you'll get:
> https://gist.github.com/3625509

So the problem was actually introduced much earlier. Most probably it
has never worked
in 32bit Ubuntu 12.04. I tried for example this old commit:


and it still fails:


I tried to test even the first commit that introduced the problem:


but while it compiled, I got some import error:

(py)vagrant at precise32:~/repos/numpy/tools$ nosetests
RuntimeError: module compiled against API version 6 but this version
of numpy is 5
ERROR: Failure: ImportError (numpy.core.multiarray failed to import)
Traceback (most recent call last):
  File "/home/vagrant/repos/numpy/py/local/lib/python2.7/site-packages/nose/loader.py",
line 390, in loadTestsFromName
    addr.filename, addr.module)
  File "/home/vagrant/repos/numpy/py/local/lib/python2.7/site-packages/nose/importer.py",
line 39, in importFromPath
    return self.importFromDir(dir_path, fqname)
  File "/home/vagrant/repos/numpy/py/local/lib/python2.7/site-packages/nose/importer.py",
line 86, in importFromDir
    mod = load_module(part_fqname, fh, filename, desc)
  File "/home/vagrant/repos/numpy/py/local/lib/python2.7/site-packages/numpy/random/tests/test_random.py",
line 1, in <module>
    from numpy.testing import TestCase, run_module_suite, assert_
  File "/home/vagrant/repos/numpy/py/local/lib/python2.7/site-packages/numpy/__init__.py",
line 137, in <module>
    import add_newdocs
  File "/home/vagrant/repos/numpy/py/local/lib/python2.7/site-packages/numpy/add_newdocs.py",
line 9, in <module>
    from numpy.lib import add_newdoc
  File "/home/vagrant/repos/numpy/py/local/lib/python2.7/site-packages/numpy/lib/__init__.py",
line 4, in <module>
    from type_check import *
  File "/home/vagrant/repos/numpy/py/local/lib/python2.7/site-packages/numpy/lib/type_check.py",
line 8, in <module>
    import numpy.core.numeric as _nx
  File "/home/vagrant/repos/numpy/py/local/lib/python2.7/site-packages/numpy/core/__init__.py",
line 10, in <module>
    import _sort
ImportError: numpy.core.multiarray failed to import

Ran 1 test in 0.002s

FAILED (errors=1)

But in any case, this seems to be a problem with the actual 32bit
Ubuntu 12.04 itself. So maybe something in gcc
has changed that now triggers the problem.


More information about the NumPy-Discussion mailing list