[Numpy-discussion] add .H attribute?
Alan G Isaac
alan.isaac at gmail.com
Tue Jul 23 08:35:01 EDT 2013
On 7/23/2013 4:36 AM, Dag Sverre Seljebotn wrote:
> I'm +1 on another name for a method that does a copy. Which can
> eventually be made redundant with A.H.copy(), if somebody ever takes on
> the work to make that happen...but at least I think the path to that
> should be kept open.
If that is the decision, I would suggest A.ct().
But, it this really necessary? An obvious path is to introduce A.H now,
document that it makes a copy, and document that it may eventually
produce an iterative view.
Think how much nicer things would be evolving if diagonal
had been implemented as an attribute with documentation
that it would eventually be a writable view. Isn't there some
analogy with this situation?
More information about the NumPy-Discussion