[Numpy-discussion] Name change of the ptp() function

Eli Bressert ebressert at gmail.com
Fri May 10 01:47:56 EDT 2013


The peak-to-peak function, ptp(), is a simple and handy function to
use, but it confuses the PEP20 suggestions a bit. See this discussion
for reference: http://d.pr/i/snXG

Based on the discussion, it may be a good idea to make the name more
relevant? Some suggestions include span() or valuerange(). Among few
others who have discussed this on Github
(https://github.com/numpy/numpy/issues/3292#issuecomment-17353454)
valuerange() appears to the best most favored one.

-Eli



More information about the NumPy-Discussion mailing list