[Numpy-discussion] Name change of the ptp() function
pav at iki.fi
Fri May 10 09:17:01 EDT 2013
10.05.2013 16:04, Eli Bressert kirjoitti:
> That's a good point regarding the range function names. But, I think
> the issue still stands on the readability of the ptp function.
> Regarding PEP20 it's stated that "readability counts."
I think here it has to be kept in mind that this function has been
called ptp() already in Numeric, i.e., for the last 10+ years. This is
the first proposal to change it that I know of, so I think keeping the
API the same weighs against changing it due to aesthetic reasons.
More information about the NumPy-Discussion