[Numpy-discussion] ANN: SciPy 0.13.0 release

Matthew Brett matthew.brett at gmail.com
Fri Oct 25 10:54:22 EDT 2013


Hi,

On Sat, Oct 19, 2013 at 2:40 PM, Ralf Gommers <ralf.gommers at gmail.com> wrote:
> On behalf of the SciPy development team I'm pleased to announce the
> availability of SciPy 0.13.0. This release contains some interesting new
> features (see highlights below) and half a year's worth of maintenance work.
> 65 people contributed to this release.
>
> Some of the highlights are:
>
>   - support for fancy indexing and boolean comparisons with sparse matrices
>   - interpolative decompositions and matrix functions in the linalg module
>   - two new trust-region solvers for unconstrained minimization
>
> This release requires Python 2.6, 2.7 or 3.1-3.3 and NumPy 1.5.1 or greater.
> Support for Python 2.4 and 2.5 has been dropped as of this release.
>
> Sources and binaries can be found at
> http://sourceforge.net/projects/scipy/files/scipy/0.13.0/, release notes are
> copied below.

Sorry to be slow to the party, but I just wanted to point out:

git shortlog -ns v0.12.0..v0.13.0

   389  Pauli Virtanen
   225  Ralf Gommers
   105  alex
   104  Blake Griffith
   101  Warren Weckesser
...

So - to y'all, but in particular to Pauli and Ralf - thank you for
this all this great, patient, organized work.

A deep bow,

Matthew



More information about the NumPy-Discussion mailing list