[Numpy-discussion] Help - numpy / scipy binary compatibility

David Cournapeau cournape at gmail.com
Fri Aug 8 23:04:57 EDT 2014


On Sat, Aug 9, 2014 at 10:41 AM, Matthew Brett <matthew.brett at gmail.com>
wrote:

> Hi,
>
> I would be very happy of some help trying to work out a numpy package
> binary incompatibility.
>
> I'm trying to work out what's happening for this ticket:
>
> https://github.com/scipy/scipy/issues/3863
>
> which I summarized at the end:
>
> https://github.com/scipy/scipy/issues/3863#issuecomment-51669861
>
> but basically, we're getting these errors:
>
> RuntimeWarning: numpy.dtype size changed, may indicate binary
> incompatibility
>
> I now realize I am lost in the world of numpy / scipy etc binary
> compatibility, I'd really like some advice.    In this case
>
> numpy == 1.8.1
> scipy == 0.14.0 - compiled against numpy 1.5.1
> scikit-learn == 0.15.1 compiled against numpy 1.6.0
>
> Can y'all see any potential problem with those dependencies in binary
> builds?
>
> The relevant scipy Cython c files seem to guard against raising this
> error by doing not-strict checks of the e.g. numpy dtype, so I am
> confused how these errors come about.  Can anyone give any pointers?
>

Assuming the message is not bogus, I would try import von_mises with a venv
containing numpy 1.5.1, then 1.6.0, etc... to detect when the change
happened.

David


> Cheers,
>
> Matthew
> _______________________________________________
> NumPy-Discussion mailing list
> NumPy-Discussion at scipy.org
> http://mail.scipy.org/mailman/listinfo/numpy-discussion
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.python.org/pipermail/numpy-discussion/attachments/20140809/8d23879d/attachment.html>


More information about the NumPy-Discussion mailing list