[Numpy-discussion] NumPy-Discussion OpenBLAS and dotblas

Ralf Gommers ralf.gommers at gmail.com
Tue Aug 12 17:02:06 EDT 2014


On Tue, Aug 12, 2014 at 10:53 PM, Sturla Molden <sturla.molden at gmail.com>
wrote:

> Ralf Gommers <ralf.gommers at gmail.com> wrote:
>
> > That's not possible. The only way you can do that is move the hard
> > dependency on BLAS & LAPACK to numpy, which we don't want to do.
>
> But NumPy already depends on BLAS and LAPACK, right?
>

No. Numpy uses those libs when they're detected, but it falls back on its
own dot implementation if they're not found. From first bullet under
http://scipy.org/scipylib/building/linux.html#generic-instructions: "BLAS
and LAPACK libraries (optional but strongly recommended for NumPy, required
for SciPy)".

BLAS/LAPACK are heavy dependencies that often give problems, which is why
you don't want to require them for the casual user that only needs numpy
arrays to make some plots for examples.

Ralf




>
> _______________________________________________
> NumPy-Discussion mailing list
> NumPy-Discussion at scipy.org
> http://mail.scipy.org/mailman/listinfo/numpy-discussion
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.python.org/pipermail/numpy-discussion/attachments/20140812/53c65c6b/attachment.html>


More information about the NumPy-Discussion mailing list