[Numpy-discussion] OpenBLAS on Mac

Jurgen Van Gael jurgen.vangael at gmail.com
Thu Feb 20 11:57:14 EST 2014

Hi All,

I run Mac OS X 10.9.1 and was trying to get OpenBLAS working for numpy.
I've downloaded the OpenBLAS source and compiled it (thanks to Olivier
Grisel). I installed everything to /usr/local/lib (I believe): e.g. "ll
/usr/local/lib/ | grep openblas"

lrwxr-xr-x   1 37B 10 Feb 14:51 libopenblas.a@ ->
lrwxr-xr-x   1 56B 10 Feb 14:51 libopenblas.dylib@ ->
-rw-r--r--   1 18M  7 Feb 16:02 libopenblas_sandybridgep-r0.2.9.rc1.a
-rwxr-xr-x   1 12M 10 Feb 14:51 libopenblas_sandybridgep-r0.2.9.rc1.dylib*

Then I download the numpy sources and add a site.cfg with the only three
lines uncommented being:

libraries = openblas
library_dirs = /usr/local/lib
include_dirs = /usr/local/include

When I run python setup.py config I get message that say that openblas_info
has been found. I then run setup build and setup install (into a
virtualenv). In the virtualenv, when I then check what _dotblas.so is
linked to, I keep getting that it is linked to Accelerate. E.g.

otool -L .../numpy/core/_dotblas.so =>

Any suggestions on getting my numpy working with OpenBLAS?

Thanks, Jurgen
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.python.org/pipermail/numpy-discussion/attachments/20140220/6b827e79/attachment.html>

More information about the NumPy-Discussion mailing list