[Numpy-discussion] Scipy 0.15.0 beta 1 release

Nathaniel Smith njs at pobox.com
Tue Nov 25 19:00:12 EST 2014


On Tue, Nov 25, 2014 at 11:50 PM, Andrea Gavana <andrea.gavana at gmail.com> wrote:
>
> On 25 November 2014 at 19:33, David Cournapeau <cournape at gmail.com> wrote:
>>
>>
>>
>> On Tue, Nov 25, 2014 at 6:10 PM, Sturla Molden <sturla.molden at gmail.com>
>> wrote:
>>>
>>> David Cournapeau <cournape at gmail.com> wrote:
>>> > Shall we consider <a
>>> >
>>> > href="https://github.com/scipy/scipy/issues/4168">https://github.com/scipy/scipy/issues/4168</a>
>>> > to be a
>>> > blocker (the issue arises on scipy master as well as 0.14.1) ?
>>> >
>>>
>>> It is really bad, but does anyone know what is really going on?
>>
>>
>> Yes, it is in the bug report.
>
>
>
> Nice move.
>
> I've now recommended to hold back any upgrade/update/pip-crap/enpkg-fun
> thing on NumPy/SciPy across the whole user base of Python in the company. We
> will probably move to 64bit-in-any-sense soon enough, I guess before this
> issue is solved. Tell me, NumPy, was the array aligned enough in 1.8? Is
> NumPy stricter in its checking because of SPARC? SPARC?!?

It's a regression in 1.9, yes; 1.8 is fine.

-n

-- 
Nathaniel J. Smith
Postdoctoral researcher - Informatics - University of Edinburgh
http://vorpus.org



More information about the NumPy-Discussion mailing list