[Numpy-discussion] [SciPy-Dev] Hamming etc. windows are wrong

Jerry lanceboyle at qwest.net
Fri Sep 26 20:10:10 EDT 2014


On Sep 26, 2014, at 2:03 PM, Paul Hobson <pmhobson at gmail.com> wrote:

> 
> 
> On Fri, Sep 26, 2014 at 3:39 AM, Jerry <lanceboyle at qwest.net> wrote:
> 
> On Sep 26, 2014, at 2:56 AM, Daπid <davidmenhur at gmail.com> wrote:
> 
>> 
>> On 26 September 2014 10:41, Jerry <lanceboyle at qwest.net> wrote:
>> **** I am just learning Python-NumPy-SciPy but it appears as though the SciPy situation is that the documentation page above *** mentions the flag but the flag has not been implemented into SciPy itself. I would be glad to stand corrected.
> 
> Hmm.... Earlier I was getting a Python error when I tried to supply the second argument, sym. That was the reason for my comment but now it accepts the second argument without complaint.
> 
> Just curious: had you imported pylab at any point? You sample code looks like you did several "from xxx import *" and it might have clobbered the scipy version (or vise versa).

I don't recall what I had imported, but probably scipy, as in "import scipy", or maybe "import scipy as sc." I do believe that I was working interactively so I don't have any actual evidence at this point.

But I just had this thought—maybe I was in numpy and not scipy. For some reason both numpy and scipy provide a hamming function (why?) so maybe I was using the numpy version by accident which IIRC does not have the second argument.

My sample code is in Octave. 8^)

Jerry
> 
> _______________________________________________
> NumPy-Discussion mailing list
> NumPy-Discussion at scipy.org
> http://mail.scipy.org/mailman/listinfo/numpy-discussion

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.python.org/pipermail/numpy-discussion/attachments/20140926/7e6b1ac3/attachment.html>


More information about the NumPy-Discussion mailing list