[Numpy-discussion] When to stop supporting Python 2.6?

Paul Hobson pmhobson at gmail.com
Fri Dec 11 01:52:23 EST 2015


On Thu, Dec 10, 2015 at 4:20 AM, Julian Taylor <
jtaylor.debian at googlemail.com> wrote:

> On 12/09/2015 12:10 AM, Ralf Gommers wrote:
>
>>
>>
>> On Wed, Dec 9, 2015 at 12:01 AM, Chris Barker <chris.barker at noaa.gov
>> <mailto:chris.barker at noaa.gov>> wrote:
>>
>>     drop 2.6
>>
>>     I still don't understand why folks insist that they need to run a
>>     (very)) old python on an old OS, but need the latest and greatest
>> numpy.
>>
>>     Chuck's list was pretty long and compelling.
>>
>>     -CHB
>>
>>
>>
>>     On Mon, Dec 7, 2015 at 1:38 AM, Sturla Molden
>>     <sturla.molden at gmail.com <mailto:sturla.molden at gmail.com>> wrote:
>>
>>         Charles R Harris <charlesr.harris at gmail.com
>>         <mailto:charlesr.harris at gmail.com>> wrote:
>>
>>         > As a strawman proposal, how about dropping moving to 2.7 and
>> 3.4 minimum
>>         > supported version next fall, say around numpy 1.12 or 1.13
>> depending on how
>>         > the releases go.
>>         >
>>         > I would like to here from the scipy folks first.
>>
>>
>> +1 for dropping Python 2.6, 3.2 and 3.3 after branching 1.11.x. We're
>> already behind other projects like ipython, pandas and matplotlib as
>> usual, so there really isn't much point in being the only project
>> (together with scipy) of the core stack to keep on supporting more or
>> less obsolete Python versions.
>>
>> Ralf
>>
>
>
> I don't see how that is a relevant point. NumPy is the lowest component of
> the stack, we have to be the last to drop support for Python 2.6. And we
> aren't yet the last even when only looking at the high profile components.
> Astropy still supports 2.6 for another release.
> Though by the time 1.11 comes out we might be so I'm ok with dropping it
> after that even when I'm not convinced we gain anything significant from
> doing so.


Purely from a user-perspective, I don't understand why the numpy team would
want to continue support Python <= 2.6 and <= 3.3. The old versions of
numpy aren't going anywhere, so they can still be used if, for example,
you're stuck on a 6-yr old license of ArcGIS, and therefore stuck on Python
2.6

I started using Python with version 2.4 or 2.5 and there was zero
discussion about supporting old Python 1.X versions then. I know those
situations are aren't directly comparable, but when can we let the past go?
-paul
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.python.org/pipermail/numpy-discussion/attachments/20151210/0f2b7262/attachment.html>


More information about the NumPy-Discussion mailing list