[Numpy-discussion] Clarification sought on Scipy Numpy version requirements.

Charles R Harris charlesr.harris at gmail.com
Fri Jun 19 16:08:10 EDT 2015


Hi All,

I'm looking to change some numpy deprecations into errors as well as remove
some deprecated functions. The problem I see is that
SciPy claims to support Numpy >= 1.5 and Numpy 1.5 is really, really, old.
So the question is, does "support" mean compiles with earlier versions
of Numpy ? If that is the case there is very little that can be done about
deprecation. OTOH, if it means Scipy can be compiled with more recent numpy
versions but used with earlier Numpy versions (which is a good feat), I'd
like to know. I'd also like to know what the interface requirements are, as
I'd like to remove old_defines.h

Chuck
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.python.org/pipermail/numpy-discussion/attachments/20150619/f77df50e/attachment.html>


More information about the NumPy-Discussion mailing list