[Numpy-discussion] Clarification sought on Scipy Numpy version requirements.
sturla.molden at gmail.com
Fri Jun 19 17:05:24 EDT 2015
Charles R Harris <charlesr.harris at gmail.com> wrote:
> I'm looking to change some numpy deprecations into errors as well as remove
> some deprecated functions. The problem I see is that
> SciPy claims to support Numpy >= 1.5 and Numpy 1.5 is really, really, old.
> So the question is, does "support" mean compiles with earlier versions
> of Numpy ?
It means there is a Travis CI build with NumPy 1.6.2. So any change to the
SciPy source code must compile with NumPy 1.6 and any later version of
There is no Travis CI build with NumPy 1.5. I don't think we know for sure
if it is really compatible with the current SciPy.
More information about the NumPy-Discussion