[Numpy-discussion] Clarification sought on Scipy Numpy version requirements.

Charles R Harris charlesr.harris at gmail.com
Fri Jun 19 17:52:06 EDT 2015

On Fri, Jun 19, 2015 at 3:05 PM, Sturla Molden <sturla.molden at gmail.com>

> Charles R Harris <charlesr.harris at gmail.com> wrote:
> > I'm looking to change some numpy deprecations into errors as well as
> remove
> > some deprecated functions. The problem I see is that
> > SciPy claims to support Numpy >= 1.5 and Numpy 1.5 is really, really,
> old.
> > So the question is, does "support" mean compiles with earlier versions
> > of Numpy ?
> It means there is a Travis CI build with NumPy 1.6.2. So any change to the
> SciPy source code must compile with NumPy 1.6 and any later version of
> NumPy.
> There is no Travis CI build with NumPy 1.5. I don't think we know for sure
> if it is really compatible with the current SciPy.

I guess this also raises the question of what versions of Scipy Numpy needs
to support. I'm thinking of removing the noprefix.h, but it doesn't cost to
leave it in as it must be explicitly included by anyone who needs it. Hmm,
maybe best to leave it be, although I suspect anyone using it could just as
well use an earlier version of Numpy.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.python.org/pipermail/numpy-discussion/attachments/20150619/0faa0438/attachment.html>

More information about the NumPy-Discussion mailing list