[Numpy-discussion] Clarification sought on Scipy Numpy version requirements.

Ralf Gommers ralf.gommers at gmail.com
Sun Jun 21 09:23:10 EDT 2015


On Fri, Jun 19, 2015 at 10:08 PM, Charles R Harris <
charlesr.harris at gmail.com> wrote:

> Hi All,
>
> I'm looking to change some numpy deprecations into errors as well as
> remove some deprecated functions. The problem I see is that
> SciPy claims to support Numpy >= 1.5 and Numpy 1.5 is really, really, old.
>

Lowest supported Scipy version in master and 0.16.x is 1.6.2. This can be
seen in the main setup.py, scipy/__init__.py and the 0.16.0 release notes.


> So the question is, does "support" mean compiles with earlier versions
> of Numpy ?
>

Indeed.


> If that is the case there is very little that can be done about
> deprecation.
>

They can be fixed in Scipy, see for example
https://github.com/scipy/scipy/pull/4378


> OTOH, if it means Scipy can be compiled with more recent numpy versions
> but used with earlier Numpy versions (which is a good feat), I'd like to
> know.
>

That's never a good idea, and in most cases raises errors on import if you
try.


> I'd also like to know what the interface requirements are, as I'd like to
> remove old_defines.h
>

This can be fixed in Scipy (see PR above); there's still a lot to do there
though. More importantly, I think Cython still relies on this API and
therefore also needs to be updated. This description of changes made in
Theano might be helpful:
http://mail.scipy.org/pipermail/numpy-discussion/2013-November/068209.html

Ralf



>
> Chuck
>
> _______________________________________________
> NumPy-Discussion mailing list
> NumPy-Discussion at scipy.org
> http://mail.scipy.org/mailman/listinfo/numpy-discussion
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.python.org/pipermail/numpy-discussion/attachments/20150621/a092a29f/attachment.html>


More information about the NumPy-Discussion mailing list